Delayed Deposits In Nigeria

Incident Report for Luno

Resolved

The issue has been resolved, and deposits are now going through.

Thank you for you patience.
Posted May 05, 2026 - 06:57 UTC

Identified

We have identified an issue that is caused by our third party that is causing delays in Deposits for Customers. Customers will experience slow responses in bank deposits.

We apologise for the inconvenience caused and we are working with the third party to resolve the issue
Posted May 04, 2026 - 13:55 UTC