Deposit errors in Australia
Incident Report for
Luno
Resolved
We have deployed a fix which has fixed the issue.
Deposits should now work as normal for new customers signing up for Luno accounts.
We appreciate your understanding in this matter.
Posted
Mar
22
,
2025
-
10:25
UTC
Identified
We have identified an issue that affects new customers who have signed up for a Luno account in Australia
Customers will receive an error when attempting to deposit.
Our team is working on this as a priority.
We apologise for any inconvenience caused.
Posted
Mar
21
,
2025
-
11:18
UTC
×
Subscribe to Incident
Subscribe to updates for
Deposit errors in Australia
via . You'll receive .