Delayed deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
All deposits and withdrawals are currently being processed without any issues.

We apologise for any inconvenience this may have caused.
Posted Jul 25, 2024 - 14:45 UTC
Monitoring
Deposits and withdrawals are being processed as normal, our team will continue to monitor them closely.
Posted Jul 25, 2024 - 10:21 UTC
Identified
We are currently experiencing intermittent delays in both deposits and withdrawals due to issues with one of our third-party providers.

We are working closely with them to get this resolved.

We apologise for any inconvenience caused and appreciate your patience.
Posted Jul 25, 2024 - 08:46 UTC