Delayed account verification

Incident Report for Luno

Resolved

The issue affecting account verification has been resolved. Our third-party service provider has recovered, and account verifications are now processing normally.

Thank you for your patience.
Posted Jan 07, 2026 - 17:08 UTC

Monitoring

We are no longer seeing errors from our third-party service provider. Account verifications are now being processed as expected.

We will continue to monitor the situation closely.
Posted Jan 07, 2026 - 16:28 UTC

Identified

Account verifications may be slower than normal due to downtime with one of our third-party service provider.

We are monitoring the situation and will provide updates as more information becomes available.
Posted Jan 07, 2026 - 15:12 UTC