Incorrect rate display for USD trading pairs
Incident Report for Luno
Resolved
This issue has been resolved and the rates shown for USD pairs have returned to normal. We apologise for any inconvenience.
Posted Jan 11, 2023 - 08:27 UTC
Monitoring
A fix has been implemented and accurate rates should start displaying shortly. We are continuing to monitor in the meantime.
Posted Jan 11, 2023 - 06:51 UTC
Identified
We have identified the issue and a fix is being implemented.
Posted Jan 11, 2023 - 06:34 UTC
Investigating
We are currently investigating an issue causing incorrect rates to be shown for some USD trading pairs at the moment, these rates are not impacting trades and our quoting will still be based on the accurate rates.
Posted Jan 11, 2023 - 05:42 UTC