Promotional code redemption issue
Incident Report for Luno
Resolved
Promo code and referral code redemption is now working without issues.
Posted Sep 20, 2022 - 06:16 UTC
Investigating
We are currently investigating an issue affecting referral and promotion code redemption. Our engineers are looking into it and we will provide an update shortly.
Posted Sep 20, 2022 - 05:41 UTC