Delayed deposits and withdrawals in Nigeria

Incident Report for Luno

Resolved

The backlog of withdrawal and deposit transactions has been successfully cleared. All pending transactions have now been processed.

We continue to monitor the situation actively and are in close contact with our payment provider to ensure the stability of our services.

Thank you for your patience and understanding.
Posted May 08, 2025 - 06:59 UTC

Update

Due to our payment provider's intermittent issues, withdrawals are currently delayed. Deposits may also be affected.

We are in contact with them and working to resolve this as quickly as possible.

We will provide updates as soon as possible.
Posted May 06, 2025 - 11:54 UTC

Identified

We are experiencing delayed withdrawals due to intermittent downtime with our payment provider.

We will provide further updates as soon as they become available.
Posted May 06, 2025 - 10:15 UTC