Delayed Instant deposits for FNB customers in South Africa
Incident Report for Luno
Resolved
We have resolved this issue, there should be no further delays with instant deposits for FNB customers.

We appreciate your understanding and patience in this matter.
Posted Nov 29, 2024 - 06:59 UTC
Identified
We have identified an issue with our payment provider that may cause delayed deposits for some customers with FNB bank accounts who use Stitch instant deposit method.

Please use alternate deposit methods such as instant buy via card or EFT/Bank transfer.

We are working with our payment provider to solve this issue immediately.
Posted Nov 26, 2024 - 08:17 UTC