Scheduled Maintenance
Incident Report for Luno
Resolved
Maintenance has completed without any degradation to service.
Posted Nov 09, 2020 - 22:10 UTC
Identified
We will be doing routine maintenance on 09 November 2020 starting at 9pm UTC, we expect this to last no longer than 30 minutes which may affect access to accounts during this time.

We'll post an update once the maintenance is complete.

Thank you for your understanding.
Posted Nov 09, 2020 - 15:13 UTC