Delays with balance updates on exchange
Incident Report for
Luno
Resolved
Update:
We can see no further delays to balance updates for high customers with orders placed.
We appreciate your patience and understanding in this matter.
Posted
Apr
21
,
2026
-
10:12
UTC
Monitoring
Update:
We have implemented a fix, and we are monitoring the results.
Updates to follow
Posted
Apr
21
,
2026
-
09:54
UTC
Identified
Current Status: Customers executing a high frequency of orders may see a delay with balance updates in their account once their order is executed.
We are working to resolve this as soon as possible. We appreciate your understanding in this matter.
Updates to follow.
Posted
Apr
21
,
2026
-
09:29
UTC
×
Subscribe to Incident
Subscribe to updates for
Delays with balance updates on exchange
via . You'll receive .