ETH/USD pair currently unavailable in United States
Incident Report for Luno
Resolved
This issue has been resolved.
Posted Jun 24, 2022 - 00:53 UTC
Identified
We have identified an issue affecting the ETH/USD pair. This pair is currently unavailable.

We are looking into this as a matter of priority.
Posted Jun 24, 2022 - 00:10 UTC