Delayed SOL withdrawals
Incident Report for Luno
Resolved
The issue affecting SOL withdrawals has been fully resolved, and withdrawals are now processing as normal.

We apologise for any inconvenience this may have caused.
Posted Jan 19, 2025 - 04:28 UTC
Update
We are still actively working to resolve the ongoing issue affecting SOL withdrawals. Our team is doing everything possible to address the situation as quickly as we can.

We sincerely apologise for any inconvenience this may be causing and appreciate your continued patience.
Posted Jan 18, 2025 - 20:03 UTC
Identified
We have identified an issue affecting SOL withdrawals, resulting in delays. Our team is actively working to resolve the situation as quickly as possible.

We will provide further updates as we have more information.

Thank you for your patience.
Posted Jan 18, 2025 - 15:39 UTC