Slow Bitcoin Sends
Incident Report for Luno
Resolved
This issue has been resolved, Bitcoin send transactions have returned to normal.

Thank you for your patience in this regard.
Posted May 16, 2023 - 12:59 UTC
Identified
We've identified an issue affecting some Bitcoin send transactions. This may result in slower than usual send times. Our team is aware of the delay and is working on a fix.

Receiving Bitcoin to your Luno wallet remains unaffected.

Updates to follow soon.
Posted May 16, 2023 - 12:05 UTC