Help Centre Unavailable
Incident Report for Luno
Resolved
We have pushed out a fix for this and the help centre is now available as expected.

Apologies for any inconvenience caused.
Posted Jan 24, 2024 - 09:04 UTC
Investigating
We are currently experiencing an issue causing the help centre to be unavailable, we are working on a fix as a priority and hope to see this resolved soon.
Posted Jan 24, 2024 - 08:51 UTC