Deposit and withdrawal delay issue in Nigeria
Incident Report for Luno
Resolved
The issue regarding delays in voucher sends via email has been resolved.

We appreciate your patience in this regard.
Posted Aug 09, 2022 - 08:38 UTC
Identified
We are currently experiencing delays with voucher sends via email in Nigeria. Customers who receive vouchers via sms will not be affected.

We are investigating this issue as a priority.

We apologise for any inconvenience and will provide an update as soon as possible.
Posted Aug 08, 2022 - 08:16 UTC