RENDER temporarily unavailable via Instant Buy and Sell

Incident Report for Luno

Resolved

RENDER is available again via Instant Buy and Sell, thanks for your patience.
Posted Jan 29, 2025 - 10:19 UTC

Identified

Customers won't be able to buy or sell RENDER via Instant Buy or Sell, this will be resolved soon - our team are working on a fix.
Posted Jan 28, 2025 - 21:52 UTC