Delayed deposits and withdrawals in Nigeria
Incident Report for
Luno
Resolved
Deposits and withdrawals are being processed as normal.
Thanks for your patience.
Posted
Nov
29
,
2024
-
12:36
UTC
Update
We are continuing to work on a fix for this issue.
Posted
Nov
29
,
2024
-
07:52
UTC
Identified
We're seeing delayed withdrawals in Nigeria, customers who have requested a withdrawal since 03:42 UTC may see longer than normal processing times.
Our team is working on a resolution.
Posted
Nov
29
,
2024
-
07:35
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits and withdrawals in Nigeria
via . You'll receive .