Delayed withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.

Thank you for your understanding.
Posted Jun 21, 2022 - 09:24 UTC
Identified
There are temporary delays with withdrawals requested on 21st June 2022, 14:00 WIB onwards. We’re working with our service provider to see this resolved and will provide an update soon.

We will attempt to process the withdrawals once this matter has been resolved. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934

Thank you for your patience.
Posted Jun 21, 2022 - 08:08 UTC