New account verifications in South Africa
Incident Report for Luno
Resolved
The backlog of customers awaiting verification is complete, this is now fully resolved.
Thanks again for your patience.
Posted Jul 18, 2021 - 19:08 UTC
Monitoring
A fix has been implemented, we're working for through backlog of failed verifications from Saturday night - customers who signed up during this time should be automatically verified shortly.
Posted Jul 18, 2021 - 18:33 UTC
Update
We're continuing to have conversations with the third party provider, we're making progress.
Sincerely sorry about the delays that this has caused.
Posted Jul 18, 2021 - 17:55 UTC
Update
The root cause of the issue has been narrowed down to the third party provider we use for account verifications in South Africa, we're attempting to contact them as a matter of urgency.

Updates to follow.
Posted Jul 18, 2021 - 16:03 UTC
Update
Customers who signed up after Saturday 17 July in South Africa will be affected, we're in the process of reviewing some errors. There is no need to do anything, we'll have this sorted out and the backlog completed shortly.
Posted Jul 18, 2021 - 14:40 UTC
Identified
We've identified an issue affecting account verifications for new customers signing up or trying to verify to Level 1 in South Africa. A fix is being worked on as a priority.
Posted Jul 18, 2021 - 14:26 UTC