Slow account verification in Indonesia
Incident Report for Luno
Resolved
No further issues, verification times have returned to normal.
Thanks for your patience.
Posted Jan 29, 2025 - 20:09 UTC
Identified
Customers signing up with Luno for the first time or customers wanting to verify to another level may see delays, this looks to be an issue with a third party we make use of.

We're working with them to resolve the issue.
Posted Jan 29, 2025 - 18:14 UTC