No information on the exchange when using web browser in Europe

Incident Report for Luno

Resolved

Update:

The exchange is functioning as expected, with all the information displaying correctly.

We appreciate your understanding in this matter.
Posted Oct 14, 2025 - 08:29 UTC

Identified

We have identified an issue causing the exchange page to show no information when using the web browser.

This is affecting European customers.

Exchange works fine on the Luno app.

Our team is working to fix this issue ASAP.

Updates to follow.
Posted Oct 14, 2025 - 08:23 UTC