Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

Thank you for your patience.
Posted May 14, 2022 - 14:07 UTC
Identified
We are currently experiencing temporary delays with withdrawal payouts.

This has been escalated to our banking partners and a resolution is in progress.

We apologize for any inconvenience.
Posted May 13, 2022 - 11:22 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).