Delayed OTP delivery in ZA

Incident Report for Luno

Resolved

The issue has been resolved, thank you for your patience.
Posted Jul 23, 2025 - 14:33 UTC

Identified

There is a network issue that is affecting OTP delivery in South Africa. This affects account verification and account recovery flows. We apologise for inconvenienced caused. Our teams are working hard to make sure the issue is resolved
Posted Jul 23, 2025 - 07:41 UTC