Delayed DOT Staking Rewards Payout

Incident Report for Luno

Resolved

Apologies for the confusing communications around this, we're consolidating updates here > https://status.luno.com/incidents/074xykcq8kyd
Posted Oct 03, 2025 - 10:50 UTC

Update

We are currently facing delays in DOT staking rewards payouts. There are delays and our team is working to fix the issue. We apologise for inconvenience caused.
Posted Oct 03, 2025 - 08:45 UTC

Identified

We are no longer seeing delays with NEAR staking and rewards are being paid out, however we are still experiencing delays with DOT rewards payouts. Our team is working to fix the delays, we thank you for your patience.
Posted Oct 03, 2025 - 07:39 UTC

Monitoring

We are no longer seeing delays with NEAR staking and rewards are being paid out, however we are still experiencing delays with DOT rewards payouts. Our team is working to fix the delays, we thank you for your patience.
Posted Oct 02, 2025 - 14:21 UTC

Investigating

We are currently facing delays in our NEAR and DOT staking and rewards payouts. There are delays and our team is working to fix the issue. We apologise for inconvenience caused.
Posted Oct 01, 2025 - 06:06 UTC