Exchange on Luno iOS App is intermittently unresponsive

Incident Report for Luno

Resolved

The issue has been resolved. IOS customers are now able to use their Luno App without any issues.
Posted Mar 27, 2025 - 05:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 27, 2025 - 05:56 UTC

Monitoring

We have updated our iOS version to fix the issue, please update the app to our latest version 8.79.3. Thank you for your patience.
Posted Mar 26, 2025 - 08:22 UTC

Investigating

We are currently investigating an issue where the Luno App is unresponsive on Exchange when using iOS. Customers are still able to use Web.
Posted Mar 25, 2025 - 13:07 UTC