Delayed Verifications in Nigeria
Incident Report for Luno
Resolved
As of 12:20 UTC there are no further delays with account verification in Nigeria.
Posted Sep 04, 2023 - 13:19 UTC
Update
Account verification times in Nigeria have returned to normal, we're continuing to monitoring closely.
Thanks again for your patience.
Posted Sep 04, 2023 - 12:40 UTC
Monitoring
As of 09:29 UTC we've started seeing good results from our third-party provider that helps verify accounts. We have a small backlog to run through, rest assured we'll have your account verified as soon as we can.
Posted Sep 04, 2023 - 10:26 UTC
Update
Our third-party provider is still experiencing intermittent downtime, resulting in continued delays for account verifications in Nigeria.

This issue started on Friday 1 September, customers attempting to verify their accounts from this date may see delays. Customers who are already verified are not impacted.

We will provide more updates as soon as they become available.

We appreciate your patience in this regard.
Posted Sep 04, 2023 - 07:06 UTC
Identified
Due to some intermittent downtime with a third party some customers in Nigeria may experience delays in account verification.

We will provide updates as soon as possible.
Posted Sep 01, 2023 - 06:28 UTC