Delayed express withdrawals in South Africa

Incident Report for Luno

Resolved

We are seeing account verifications in South Africa and Nigeria being processed as normal.

We apologise for any inconvenience and thank you for your patience in this regard.
Posted Oct 02, 2023 - 09:50 UTC

Monitoring

Express withdrawals to FNB customers are processing as normal, however we've seen some intermittent delays from Standard Bank processing express withdrawals.

Our team is in contact with the bank, working hard to process these as normal, and will provide an update once the bank has confirmed that everything is back to normal.
Posted Oct 02, 2023 - 09:21 UTC

Update

We haven't received confirmation from the banks that this has been resolved. Our team is in contact with the bank, working hard to process these as normal.

We will update you as soon as we have further information.

Thanks for your patience.
Posted Sep 29, 2023 - 14:25 UTC

Identified

There may be temporary delays with express withdrawals requested to FNB. The bank is urgently working on having this resolved. Our bank is in contact with FNB to resolve this.

We will update you as soon as we have further information.
Posted Sep 29, 2023 - 08:10 UTC