Enable cryptocurrency sends delay

Incident Report for Luno

Resolved

The issue affecting customers enabling cryptocurrency sends has been fully resolved. Customers can now enable cryptocurrency sends normally.

We apologise for any inconvenience caused and appreciate your patience while we worked to resolve the issue.
Posted Jun 02, 2026 - 15:01 UTC

Monitoring

A fix has been implemented to mitigate the issue affecting customers enabling cryptocurrency sends. Customers should now be able to enable sends normally.

We are monitoring the situation to ensure everything remains stable.
Posted Jun 02, 2026 - 14:53 UTC

Identified

We have identified an issue affecting customers trying to enable cryptocurrency sends.

Customers who have their cryptocurrency sends disabled may experience a delay or loop when trying to enable cryptocurrency sends.

Customers who already have sends enabled will not be affected

Our team is working on the fix as a priority.

Updates to follow
Posted Jun 01, 2026 - 14:29 UTC