Delayed Price Updates for Certain BTC Pairs
Incident Report for Luno
Resolved
This issue has been resolved and price updates have returned to normal.
Posted Jan 13, 2022 - 08:14 UTC
Identified
We have identified an issue that may be causing delays in price updates for certain BTC pairs, we are working on this as a priority.
Posted Jan 12, 2022 - 21:01 UTC