Limited website access
Incident Report for Luno
Resolved
Monitoring has been concluded and the issue has fully been fixed.
Posted Sep 21, 2022 - 09:44 UTC
Monitoring
We are still monitoring to ensure that our website is working optimally.
Posted Sep 21, 2022 - 09:32 UTC
Investigating
We experienced an intermittent issue with accessing website pages that require authentication. Rest assured, all accounts are safe and we have fixed the issue. We are still addressing any minor issues and investigating the issue further. We apologize for the inconvenience.
Posted Sep 21, 2022 - 09:08 UTC