Scheduled Maintenance affecting withdrawals in South Africa

Incident Report for Luno

Resolved

The maintenance has been successfully completed.

All withdrawal methods should be working as per normal.

Thank you for your patience and understanding in this matter.
Posted Jul 03, 2025 - 20:55 UTC

Identified

Please be advised that we will be conducting planned maintenance on our bank account verification system for South African withdrawals.

You may experience delays or not be able to make withdrawals during this maintenance downtime.

Date: 2024-07-03

Time: 21:00 (UTC +2)

We apologise for the inconvenience this may cause and will post an update once the maintenance has been completed.

Thanks for your understanding.
Posted Jul 03, 2025 - 06:38 UTC