Public Holiday Reminder - Withdrawal Request will take longer than usual in the United States
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 16:45 UTC
Identified
Monday, January 16th is a public holiday in the United States, during which banks do not process payments. This means any withdrawals from Luno that we send to the banks won’t be processed by them until Tuesday, January 17th.

Please note that this only applies to USD withdrawals. Crypto withdrawals are being processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jan 13, 2023 - 21:24 UTC