Delayed account verification in South Africa
Incident Report for Luno
Resolved
We are seeing account verification processing as normal.

Thank you for your patience and understanding.
Posted Dec 13, 2024 - 09:37 UTC
Monitoring
A fix has been successfully implemented for the issue affecting account verification. Our team is actively monitoring the results to ensure everything is functioning as expected.
Posted Dec 13, 2024 - 07:13 UTC
Identified
We have identified an issue with one of our third-party verification providers, which may be causing delays or issues with account verification.

Our team is actively working with the provider to resolve the issue as quickly as possible.

We will continue to provide updates as we work to fix the situation.
Posted Dec 13, 2024 - 07:05 UTC