Delayed deposits via vouchers in Nigeria
Incident Report for Luno
Resolved
All deposits have been successfully allocated with new deposits working well.

Thank you for your patience.
Posted Nov 24, 2022 - 14:05 UTC
Monitoring
Deposits are being processed as normal, however, we’re still working through a small backlog of deposits made between 22 and 23 November 2022.
Posted Nov 23, 2022 - 13:44 UTC
Identified
Customers making NGN deposits via vouchers will, unfortunately, see delays in having the NGN Wallet credited. We’re working hard to get this back up and running.

Withdrawals remain unaffected.

Updates to follow.
Posted Nov 23, 2022 - 09:47 UTC