Luno Platform Outage
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any disruptions to Luno's Platform. All services are working as normal.
We appreciate your understanding and patience in this matter.
Posted
Dec
12
,
2025
-
13:24
UTC
Monitoring
Update:
We can see that Luno's Platform is restored as normal and we are monitoring for any further issues
We appreciate your patience and understanding in this matter.
Posted
Dec
12
,
2025
-
13:10
UTC
Identified
We have identified an issue that is causing Luno's platforms (Website, APP, and API) to be inaccessible to our customers.
Our team is investigating the cause and working to restore full service as quickly as possible.
Posted
Dec
12
,
2025
-
12:41
UTC
×
Subscribe to Incident
Subscribe to updates for
Luno Platform Outage
via . You'll receive .