Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Aug 18, 2022 - 02:39 UTC
Identified
Certain withdrawals in Indonesia will not be processed on 17th August 2022 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Such withdrawals will be processed on 18th August 2022.

For more information on this, please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Aug 16, 2022 - 10:07 UTC