Delayed LTC sends
Incident Report for Luno
Resolved
The issue has been resolved and LTC sends have returned to normal.
Posted Nov 24, 2021 - 17:36 UTC
Investigating
We are investigating an issue causing a delay in LTC sends.

We're hoping to see this resolved soon and are working on this as a priority.
Posted Nov 24, 2021 - 09:12 UTC
This incident affected: Crypto sends and receives (LTC).