Delayed orders for BTC/UGX
Incident Report for Luno
Resolved
This issue has been resolved and orders for the BTC/UGX pair are being processed as normal.
Posted May 10, 2022 - 10:19 UTC
Investigating
We are currently investigating an issue causing delayed orders for the BTC/UGX pair, we are working on a fix as a priority and will update here as soon as possible.
Posted May 10, 2022 - 09:19 UTC