Delayed Withdrawals In Nigeria

Incident Report for Luno

Resolved

This is issue has been resolved. We thank you for your patience.
Posted Jul 23, 2025 - 07:03 UTC

Investigating

We are currently experiencing some issues causing withdrawals for Nigerian customers to be delayed. We are working to promptly resolve this and will provide further updates as soon as we can. Thank you for you patience.
Posted Jul 22, 2025 - 16:52 UTC