Delayed withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Jun 22, 2021 - 07:02 UTC
Identified
Some customers may see a delay in their MYR withdrawal request if they have verified their account using a MyKad number. Our team are aware of the delay and are working on a fix.
Posted Jun 21, 2021 - 14:13 UTC