Slow Bank Deposits in Nigeria

Incident Report for Luno

Resolved

This incident has been resolved. , deposits are working as normal.

Thank you for your patience.
Posted Mar 08, 2023 - 13:00 UTC

Investigating

We are aware of an issue that is causing customers to experience delays in deposits via vouchers in Nigeria. We are looking into this and will provide an update as soon as possible.

We apologise for any inconvenience.
Posted Mar 08, 2023 - 09:26 UTC