Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
MYR Withdrawals are now being processed as scheduled. Thank you
Posted Nov 21, 2022 - 03:30 UTC
Identified
Withdrawals in Malaysia will not be processed on 18th November 2022 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Withdrawals requested during this time will be processed on 21st November 2022.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Nov 17, 2022 - 06:19 UTC