Deposits in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 07, 2021 - 06:27 UTC
Monitoring
The service upgrade has been completed. We are receiving deposits as usual now.
Posted May 07, 2021 - 06:27 UTC
Investigating
Our provider will be performing a service upgrade on Thursday, 6th May 2021 between 9:30 – 10:30PM AEST. During this downtime, we will not be able to receive any deposits.

Please avoid making deposits during this interrupted period.
Posted May 05, 2021 - 02:07 UTC