Slow deposits in Nigeria
Incident Report for Luno
Resolved
We can confirm that all deposit requests are now being processed successfully. Thank you for being patient.
Posted Sep 10, 2022 - 17:49 UTC
Investigating
We are aware of an issue causing some deposits to be unsuccessful via vouchers in Nigeria.

We hope to see this resolved as soon as possible.

We apologise for any inconvenience caused.
Posted Sep 10, 2022 - 11:01 UTC