Delayed withdrawals

Incident Report for Luno

Resolved

This issue has been resolved and after further monitoring we have seen no other issues with withdrawals.

We thank you for your patience in this regard.
Posted Sep 06, 2023 - 14:16 UTC

Monitoring

A fix has been implemented to address the issue causing withdrawals to be delayed or fail.
We are continuing to monitor for further anomalies.

Thank you for your patience in this regard.
Posted Sep 05, 2023 - 13:51 UTC

Investigating

We are currently investigating an issue that is causing some customer's withdrawals to be delayed or fail.

We are looking into this as a matter of priority and will provide updates as soon as they become available.
Posted Sep 05, 2023 - 13:42 UTC