Order Balance Update Delays

Incident Report for Luno

Monitoring

A fix has been implemented, and we are seeing order balances updating normally across the exchange. Any previously delayed funds are actively being processed and will reflect in your account.

Our team will continue to monitor system performance closely to ensure full stability.
Posted Jul 03, 2026 - 18:39 UTC

Identified

We have identified the cause of this issue and are working on a fix.

We hope to see this resolved soon and will provide updates as soon as possible.
Posted Jul 03, 2026 - 18:34 UTC

Investigating

We are currently investigating an issue causing delayed balance updates for some customers.

We are working on this as a priority and will provide updates as soon as possible
Posted Jul 03, 2026 - 17:57 UTC