BCH is temporarily unavailable on Instant Buy and Sell

Incident Report for Luno

Resolved

We are no longer seeing any issues with the Bitcoin Cash (BCH) / Bitcoin (BTC) pair on instant buy and sell.

We appreciate your understanding in this matter.
Posted Aug 24, 2025 - 10:09 UTC

Identified

We have identified an issue causing Bitcoin Cash (BCH) / Bitcoin (BTC) pair to be temporarily unavailable for customers using instant buy and sell.

Our team is working on this as a priority.

We will update as soon as possible and appreciate your understanding in his matter.
Posted Aug 24, 2025 - 09:52 UTC