Unable to submit emails to our team
Incident Report for Luno
Resolved
We aren't seeing any further error rates, thanks again for your patience.
This has been fully resolved.
Posted Sep 27, 2021 - 07:22 UTC
Monitoring
We're starting to see emails come in and error rates drop, thanks for your patience.
We'll continue to monitor until the provider reports this as fully resolved.
Posted Sep 27, 2021 - 05:57 UTC
Update
Unfortunately the issue still remains, an error is displayed when attempting to submit an email to our team via the Help Centre on both the Android & iOS apps and luno.com.
Posted Sep 27, 2021 - 04:24 UTC
Identified
The provider we use to manage our email submissions from the Help Centre appear to be having some issues, customers are unable to submit an email to our team via the Help Centre.

We hope to see this resolved shortly.
Posted Sep 27, 2021 - 03:25 UTC