Delayed XRP sends

Incident Report for Luno

Monitoring

We are no longer experiencing delays with XRP sends. Our team will continue to monitor the situation for any further issues.
Posted Aug 02, 2026 - 08:31 UTC

Identified

We are currently experiencing an issue causing XRP withdrawals to be delayed.

We have identified the issue and are working to resolve it as soon as possible.
Posted Aug 02, 2026 - 04:47 UTC