PayU Instant EFT deposits temporarily unavailable in South Africa
Incident Report for Luno
Resolved
This issue has been resolved.

Thank you for your patience.
Posted Sep 30, 2021 - 09:47 UTC
Monitoring
PayU deposits are now being processed successfully. We will continue to monitor for any further errors.
Posted Sep 30, 2021 - 08:50 UTC
Investigating
Instant EFT with PayU deposits may fail for some customers. We are working to get this issue resolved. In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted Sep 30, 2021 - 07:37 UTC